x
login Signup

Unable to run Procedure in Impersonate credentials

We are struggling with such a silly issue and you might help me out. We have just created Electric Commander V5.4 Test server and one external Agent. But Unfortunately I am unable to run the Procedure in impersonate credentials which is requirement. If we are not using impersonation credentials its working fine. Below are the details:-

  1. We want to upgrade our prod server to latest server therefor first we want to migrate existing Projects to test server for sanity then we will upgrade to required version.

  2. MySQL server, Web Server and Commander Server installed on single machine. Installed software in advanced mode due to external DB connectivity which is MYSQL.

  3. One agent host created to run the jobs RHEL5.

  4. For information I would like to say that this agent machine is working fine with production server without any issue in impersonate mode.

Error we are facing after running the job is

HTTP ERROR: 500

Problem accessing /workspaces/svgtest-commander/resources/ldvopt209/jobSteps/5126ef58-db1d-11e7-8b6a-5cf3fc4b2fd4/test.5126ef58-db1d-11e7-8b6a-5cf3fc4b2fd4.log. Reason:

    AsyncContext#dispath s=DISPATCHED i=false a=null

Powered by Jetty://

HTTP ERROR: 500

Problem accessing /workspaces/svgtest-commander/resources/ldvopt209/jobSteps/5126ef58-db1d-11e7-8b6a-5cf3fc4b2fd4/test.5126ef58-db1d-11e7-8b6a-5cf3fc4b2fd4.log. Reason:

    AsyncContext#dispath s=DISPATCHED i=false a=null

Powered by Jetty://

and then Step error [AgentInternalError]: unable to run the command on the agent     Unspecified internal error on the agent: ecimpersonate: error reading ecwrapper pid from su output: TIMEOUT      Can you please give your inputs where we did silly mistake and we are stuck more than a week to resolved the issue.

avatar image By avtar00006 15 asked Dec 18, 2017 at 04:45 PM
more ▼
(comments are locked)
10|750 characters needed characters left

2 answers: sort voted first

This issue appears to have been caused due to workspace permissions issues. Please confirm if this issue is resolved now.

avatar image By vpalaiya 15 answered Jan 04 at 09:29 PM
more ▼
(comments are locked)
10|750 characters needed characters left

Yes its working fine. There was issue with Works Space. ,Yes its working fine now. There was issue with workspace.

avatar image By avtar00006 15 answered Jan 08 at 11:50 AM
more ▼
(comments are locked)
10|750 characters needed characters left
Your answer
toggle preview:

Up to 8 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.