x
login Signup

step is still running..

Guys, we have EF Version 5.4 deployed on rhel5 with external DB MySQL. Additionally we have one Agent Machine RHEL5.

Now, I have one very silly hurdle that I am unable to catch that ectool commands does not responding from EF Project if I am using impersonation credentials. Whenever I am running any ectool command job log message is step is still running even for ectool getProjects command. There is no error message or output. Step is continuously running infinitely.

In addendum whenever I am trying to run the same job using default agent user the job gives the output as per the expectation.

Also I would like to mention that rest of jobs wherever I am not using ectool command working fine using impersonation credentials. For example if I want to print the environment variables .

Server RHEL5.4 Agent RHEL5.4

You inputs would be much appreciated as I stuck with issue more than 15 days and EC support team also unable to find the solution.

Thanks & Regards, Avtar Singh

avatar image By avtar00006 15 asked Jan 09 at 07:22 AM
more ▼
(comments are locked)
10|750 characters needed characters left

1 answer: sort voted first

Hi Avtar,

I see this is a continuation of the previous question, and while my answer there may be helpful for the normal case, I think you have a more special situation where that information may not be enough.

I also see you are working with the support team. Let's keep doing that. In the meantime, I'll post some more here. You may have seen some of these answers from the support team already, but it doesn't hurt to put them in the online Q&A.

Seeing how your problem only happens when you use impersonation credentials, but not plain-old credentials, the short tests are about determining if the user account has permissions on that workspace and/or ectool.

  1. Are you able to log on as the impersonated user and run the command from the same directory as the workspace? I have not yet seen your problem, but I am wondering if the user doesn't have permissions to write files in the workspace and what you see are the hung steps.

  2. Are you able to run a diagnostic step such as echo "hello world" on the command-line using impersonation? This will help us understand if there is a permissions issue running the ectool command. This won't solve the problem, but it is additional information to help determine what permissions your impersonated user has.

  3. Am I correct this problem with using an impersonated user also exists on other servers? This includes the local agent on the server. This will help us figure out if the problem is specific to the agent or common to all servers in your system.

The last couple of ideas are around how the user accounts may be setup and I will attempt to explain as best I can. I believe we do a super-user (su) to impersonate. Somewhere in the process, umask and tty options come into play, and I have seen some combinations create problems. In the past, if the system account (the user which we run the agent service) or the impersonated user with "su" commands, then we see problems. Normally, this is not a problem but sometimes local IT groups establish extra security protocols. Here is where I would need the help of somebody else to comment further.

avatar image By marcoman 2.2k answered Jan 09 at 01:58 PM
more ▼
(comments are locked)
10|750 characters needed characters left
Your answer
toggle preview:

Up to 8 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.